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BEFORE YOU BEGIN 

Welcome to the user guide for the Fast Input Mechanism software. In this user guide, 

you will learn how to use the features in the software, namely: 

� Create house assessments for analysis, and 

� Exporting assessments to the AccuRate engine. 

The screen shots shown in this document are taken on the Microsoft Windows XP 

Professional SP2 platform. If you are using a different platform, you may see a slightly 

different view. However, the look and feel of the system has been carefully designed 

so that the differences are minute and have no consequence to the operation as well 

as output of the system. 

Note – CSIRO is not responsible for the availability of third-party web sites mentioned 

in this document and does not endorse and is not responsible or liable for any content, 

advertising, products, or other materials on or available from such sites or resources. 

CSIRO will not be responsible or liable for any damage or loss caused or alleged to be 

caused by or in connection with use of or reliance on any such content, goods, or 

services available on or through any such sites or resources. 

How this guide is organized 

Chapter 1 describes the software requirements for the Fast Input Mechanism system, 

gives step-by-step installation instructions, and shows how to start Fast Input 

Mechanism. This chapter includes a descriptive list of the installed Fast Input 

Mechanism directories. 

Chapter 2 provides step-by-step instructions for creating an assessment of a typical 

Australian house. 

Chapter 3 presents a hypothetical case study and illustrates how Fast Input 

Mechanism can be used to manage the assessment process. 

Chapter 4 explains troubleshooting techniques to common errors that may be 

encountered while creating information maps. 
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Typographic conventions 

Typeface Meaning Example 

AaBbCc123 The names of commands, files, and 
directories; on-screen computer output 

Open the data file data.fia. 

AaBbCc123 What you type. Assessment name: House 1 

AaBbCc123 Book titles, new words or terms, words to be 
emphasized. 

This menu item creates a temporary 
assessment for the selected object. 

CSIRO welcomes your comments 

CSIRO is interested in improving its documentation and welcomes your comments and 

suggestions. Email your comments to CSIRO at this address: yongbing.khoo@csiro.au 

Please include the title and version number of your document in the subject line of your 

email. 
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1. GETTING STARTED 

In this chapter, you will be introduced to the software required to install and run the 

Fast Input Mechanism system. Furthermore, detailed step-by-step installation and 

operating instructions will be provided. This chapter concludes with a descriptive list of 

the files that you can find in the Fast Input Mechanism installation directory on your 

machine. 

1.1 Software requirements 

You will need the following software in order to operate Fast Input Mechanism. 

� Microsoft Windows XP. 

� Adobe Acrobat Reader. 

� (Optional) Java Standard Edition (JavaSE) 6. Fast Input Mechanism setup 

packages are divided into two categories: with Java Virtual Machine (JVM) and 

without JVM. If you already have JavaSE, or an equivalent JVM, installed on your 

machine, then you can use setup packages that do not contain JVM. Otherwise, 

you must use the category of setup packages with JVM. Currently, the packages 

are only available for the Microsoft Windows platforms. 

1.2 Hardware requirements 

� PC with 2 gigahertz (GHz) or higher processor clock speed recommended; Intel® 

Core™ 2 Duo processor family, or AMD Phenom™ family, or compatible 

processors recommended.  

� 1 gigabyte (GB) of RAM or higher recommended. 

� 200 MB of available hard disk space. 

� XGA (1024 × 768) or higher-resolution video adapter and monitor. 

� Keyboard and Mouse or compatible pointing device. 
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1.3 Installing Fast Input Mechanism 

If your machine does not have a JVM already installed, then you need to use the setup 

package that bundles a JVM in it. The packages are executables that can be run 

directly. The following instructions are for the installation of Fast Input Mechanism on 

Microsoft Windows. The installation process is similar for all other platforms except for 

the invocation of the setup package, which is platform dependent.  

1. Double-click on setup.exe. The installer will extract the necessary files from the 
setup package and display a screen similar to Figure 1 when the extraction is 
complete. 

 

Figure 1     Start of the installation process. 

2. Follow the installer’s instructions to customize your Fast Input Mechanism 
installation. At the end of the process, you should see a screen similar to Figure 2. 

 

 

Figure 2     Completion of the installation process. 
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1.4 Starting Fast Input Mechanism 

Once the installation process has been completed successfully, a shortcut to the Fast 

Input Mechanism program will be added to your Programs menu (unless you choose 

not to install shortcuts). The default installation places the shortcut in the Fast Input 

Mechanism sub-menu as shown in Figure 3.  

 

Figure 3     Shortcut to the Fast Input Mechanism. 

1.5 Exploring the Fast Input Mechanism installation 
directories 

Fast Input Mechanism’s setup package will create files in the directories (relative to 

your selected installation directory) as shown in Table 1. 

Table 1     Directories created during the Fast Input Mechanism installation process. 

Directory Purpose 

\ Installation directory of Fast Input Mechanism. 

\bin Contains the libraries used by Fast Input Mechanism as well as the main executable file. 

\bin\configuration Contains the configuration file used to initialize Fast Input Mechanism. 

\bin\jre Contains the JVM needed to run Fast Input Mechanism. If you used the setup package without 
JVM, then this directory will not be created. 

\bin\plugins Contains the libraries that Fast Input Mechanism uses. These libraries include code as well as 
images. 

\sample Sample Fast Input Mechanism data files. 
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2. USING FAST INPUT MECHANISM 

This chapter explains how common tasks, such as creating new maps, adding sub-

processes, and editing object properties, are performed in Fast Input Mechanism. You 

can also refer to Chapter 3, “Troubleshooting common problems,” for other operations. 

Figure 4 shows a typical screen shot of the Fast Input Mechanism system.  

 

Figure 4     A typical Fast Input Mechanism screen. 
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2.1 Creating a new assessment 

The create new assessment function can be activated in two ways: 

1. The File menu (Figure 5).  

� Click on the File Menu (or press Alt-F). 

� Click on the New menu item (or use the cursor keys to move the highlight bar to 

the menu item and press Enter). 

  

Figure 5     The create new assessment function in the File menu. 

2. Keyboard hot key.  
� Press Ctrl-N. 

Using one of the above methods, a new embedded window for the newly created 

assessment will be displayed. The window will be added as a tabbed area to the left of 

the main window. This new window will look similar to Figure 4. New assessments are 

created as temporary files (with the extension .tmp). After you make changes to the 

assessment, you will be able to save it as a Fast Input Assessment (.fia) file. 
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2.2 Saving a currently-opened assessment 

Similar to the create new assessment function, the open existing assessment function 

can be activated in two ways: 

1. The File menu (Figure 6).  

� Click on the File Menu (or press Alt-F). 

� Click on the Save menu item (or use the cursor keys to move the highlight bar 

to the menu item and press Enter). 

  

Figure 6     The save assessment function in the File menu. 

2. Keyboard hot key.  
� Press Ctrl-S. 
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2.3 Opening an existing assessment 

The open existing assessment function can be activated in two ways: 

1. The File menu (Figure 7Figure 7).  

� Click on the File Menu (or press Alt-F). 

� Click on the Open menu item (or use the cursor keys to move the highlight bar 

to the menu item and press Enter). 

  

Figure 7     The open existing assessment function in the File menu. 

2. Keyboard hot key.  
� Press Ctrl-O. 
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2.4 Setting your details as an Assessor 

You can customize Fast Input Mechanism by setting your details as the Assessor in 

the Preferences dialog box. The dialog box can be accessed by: 

1. The Edit menu (Figure 8).  

� Click on the Edit Menu (or press Alt-E). 

� Click on the Preferences menu item (or use the cursor keys to move the 

highlight bar to the menu item and press Enter). 

  

Figure 8     The edit preference function in the Edit menu. 
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2. The Preferences dialog box (Figure 9).  

� Click on the Fast Input Mechanism item to expand it (or use the cursor 

keys to move the highlight bar to the item and press the Right cursor key). 

� Click on the Assessor item to select it (or use the cursor keys to move the 

highlight bar to the item). 

 

Figure 9     The Assessor preferences dialog box. 
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2.5 Setting the location of your AccuRate engine 

In order to help you analyse the results of your assessment, the Fast Input Mechanism 

needs to know the location of your AccuRate analysis engine. The location can be 

customized in the Preferences dialog box: 

1. The Edit menu (Figure 8).  

� Click on the Edit Menu (or press Alt-E). 

� Click on the Preferences menu item (or use the cursor keys to move the 

highlight bar to the menu item and press Enter). 

2. The Preferences dialog box (Figure 10).  

� Click on the Fast Input Mechanism item to expand it (or use the cursor 

keys to move the highlight bar to the item and press the Right cursor key). 

� Click on the Installed AccuRate item to select it (or use the cursor keys to 

move the highlight bar to the item). 

 

Figure 10     The Installed AccuRate preferences dialog box. 
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2.6 Entering data in the Pre-Assessment page 

When a new assessment is created, Fast Input Mechanism generates a temporary file 

and displays two tabbed pages in the left side of the main window. You are 

recommended to fill in details of the pages in sequence (from left to right). The first 

page is the Pre-Assessment component of your assessment (Figure 11). 

 

Figure 11     The Pre-Assessment page in a new assessment. 

The post code is a mandatory field in this page. You have to fill in a valid Australian 

post code for the analysis engine to use the appropriate climate information. A small 

red cross will be displayed at the top left corner of the post code text field if an invalid 

(or no) post code is detected. To get more information about correcting the error, move 

your mouse cursor over the red cross (Figure 12). 

 

Figure 12     A tooltip containing possible resolution to the error in the Pre-Assessment page. 
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2.7 Entering data in the General Assessment page 

The second page of your assessment is the General Assessment component 

(Figure 13). 

 

Figure 13     The General Assessment page in a new assessment. 

The houses that may be assessed in your assessment (Figure 14) are changed 

according to the values that you enter into this page. The library of supported houses 

is revised in new versions of the Fast Input Mechanism software. Early versions of the 

software may contain limited number of houses.   

 

Figure 14     Choosing a house type to assess. 
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2.8 Entering data in the External page 

The third page of your assessment is the External assessment component (Figure 

15). In this page, you can fill in the details of the external components of your house 

under assessment. These details include the azimuth, exposure, ground reflectance, 

external wall properties, and roof properties. Default values of these details will be 

filled in for you. 

 

Figure 15     The External assessment page in a new assessment. 
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2.9 Entering data in the Internal page 

The fourth page of your assessment is the Internal assessment component (Figure 

16). In this page, you can fill in details of the internal components of your house under 

assessment. These details include the properties of the ceiling, floor, internal wall, and 

rooms. Default values of these details will be filled in for you.  

In addition to using the text boxes in the Zones section (e.g. Length of Bed 4), you can 

also use the corresponding text boxes in the Floor plan on the right of the Fast Input 

Mechanism window. (Fast Input Mechanism defines the length as the “vertical” 

distance and width as the “horizontal” distance between two distinct points.) In Figure 

16, the length of Bed 4 is 3610 mm. Its width is 3315 mm.   

 

Figure 16     The Internal assessment page in a new assessment. 
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2.10 Exporting data to the analysis engine 

1. The File menu (Figure 17).  

� Click on the File Menu (or press Alt-F). 

� Click on the Export sub-menu (or use the cursor keys to move the highlight 

bar to the sub-menu and press Enter). 

� Click on the To AccuRate XML menu item (or use the cursor keys to move 

the highlight bar to the menu item and press Enter). 

 

Figure 17     The Export to AccuRate XML function in the File menu. 
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2. The Save File dialog box (Figure 18).  

� Navigate to the folder in which you wish to save your exported assessment. 

� Enter the file name of your exported assessment. The file name must end with 

the extension .xml. 

� Click on the Save button. 

 

Figure 18     The Save File dialog box that is displayed when your assessment is exported. 

� Click on the OK button in the dialog box after the export is completed (Figure 

19). 

 

Figure 19     The Export completion dialog box. 
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3. The Analysis dialog box (Figure 20).  

� If you wish to perform an analysis of your assessment, click on the Yes button. 

 

Figure 20     The Analysis dialog box. 

� A window will be displayed briefly when the analysis is being performed. Upon 

completion, click on the Yes button in the dialog box (Figure 21) to view results 

of the analysis (Figure 22). 

 

Figure 21     The dialog box that is displayed when the analysis is completed. 

 

Figure 22     Results of the analysis of your assessment. 
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4. The Analysis dialog box (Figure 20).  

� If you do not wish to perform an analysis of your assessment, click on the No 

button. 

� A dialog box will appear to ask if you wish to open your assessment in 

AccuRate. Click the Yes button to see the window in Figure 23. 

 

Figure 23     Opening your exported assessment in AccuRate. 

 

 



CASE STUDY 

User Guide for the Fast Input Mechanism  •  23 May 2009, Version 1.0    25 

3. CASE STUDY 

One of your clients, John Doe, has asked you to perform an energy efficiency 

assessment of his house. In response, send him an email asking for his particulars 

and details of his house (Figure 24). 

 

 

Figure 24     Sending an email to your client to request for information. 
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Upon receipt of John’s reply, create a new assessment in Fast Input Mechanism and 

populate the Pre-Assessment and General pages. Your assessment will look 

similar to Figure 25 and Figure 26.  

Leave the House type selection field empty. 

Save your assessment as a .fia file. 

 

Figure 25     The Pre-Assessment page for John Doe’s house. 

 

Figure 26     The General Assessment page for John Doe’s house. 
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Arrange a time with John to visit his house. After arriving at his house,  

� Verify with John that the layout of his house matches House 1. 

� Select House type 1 from the drop box of the House type selection field. 

� Click on the Start assessment button. Two more tabbed pages will be created 

for your assessment and the corresponding Floor plan will be drawn on the right 

side of your Fast Input Mechanism window (Figure 27). 

� Assess the external parts of the house to sequentially fill in the External 

assessment page. 

� Save your assessment. 

 

Figure 27     The External assessment page for John Doe’s house. 
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After you have finished entering the data fields in the External assessment page, 

enter John’s house to assess the internal parts: 

� Click on the Internal assessment page’s tab. 

� Enter the information relating to Ceiling, Floor, and Internal wall. 

� Go to Bed 1 of the house. 

� Measure the length and width of Bed 1. 

� Enter the measured values using either: 

� The text boxes for length and width under Bed 1, or 

� The text boxes placed along the sides of Bed 1 in the Floor plan (Figure 28). 

� Complete the rest of the Internal assessment page sequentially. 

� Save your assessment. 

 

Figure 28     The Internal assessment page for John Doe’s house. 
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At this stage, you have already gathered all the information that Fast Input Mechanism 
requires to perform an analysis of John’s house: 

� Export your assessment as an AccuRate XML file. 

� Click on the OK button in the dialog box after the export is completed. 

� Click on the Yes button in the Analysis dialog box to start the analysis of your 

assessment of John’s house. 

� Wait for the analysis to complete. 

� Click on the Yes button in the Analysis completed dialog box to view the 

analysis results (Figure 29). 

 

Figure 29     Analysis results of John Doe’s house. 

Congratulations! You have completed your first Fast Input Mechanism house 

assessment. We hope the process was enjoyable and productive for you.  

Your comments and feedback are greatly appreciated. 
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4. TROUBLESHOOTING COMMON PROBLEMS 

Check these questions first if you encounter problems when using the Fast Input 

Mechanism software. If you need additional help, please contact the Green Loans 

Program (GLP) support team at Department of the Environment, Water, Heritage and 

the Arts (DEWHA). 

1. How do I save my new assessment as a .fia file? 

When assessments are first created, the Fast Input Mechanism software 

generates a temporary .tmp file. Once you edit this temporary file, the software 

will enable the Save function in the File menu. 

2. How do I change specific features of the house (e.g. the ceiling height of Bedroom 
1 only)? 

During the design of the Fast Input Mechanism software, common features of 

supported typical houses that may affect the analysis results significantly were 

identified. This was done so that you do not have to fill in trivial data (e.g. repetition 

of the same data such as the ceiling height which is usually the same throughout a 

house).  

Nonetheless, you may encounter cases where it is important for you to capture 

these special cases in your assessment. There are at least two possible solutions: 

� Contact the GLP support team to discuss the addition of your assessed house 

as a supported typical house. (This is useful when the house is encountered 

frequently in your assessment process.) 

� Edit your assessment in AccuRate which provides many features to support 

your requirements for fine-grained and precise house assessments.   

3. Why is online help not available? 

We understand the importance of including help contents in Fast Input Mechanism. 

Regrettably, we are unable to include online help in this version. However, you are 

most welcome to contact the GLP support team for assistance. 





 

 

 

 


